import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:[,.]\\d+)*";
final String string = "mixed string123,456,00indeed\n"
+ "mixed string123,456.00indeed\n"
+ "mixed string123,4indeed\n"
+ "mixed string123,40indeed\n"
+ "mixed string 1,0\n"
+ "mixed string 34.\n"
+ "mixed string 21\n"
+ "mixed string 1,00indeed\n"
+ "mixed string 1,00.00indeed";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}