using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(.*\d){5,})[a-z0-9-]+$";
string input = @"azv1232
v1v1v1v1v1v1
v1v1v1v1v1
xyzyzyzyzyzyzyzyzy
12345
1234
a1a1a1a1a1";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}