$re = '/^(?!(.*\d){5,})[a-z0-9-]+$/mi';
$str = 'azv1232
v1v1v1v1v1v1
v1v1v1v1v1
xyzyzyzyzyzyzyzyzy
12345
1234
a1a1a1a1a1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);