re = /^(?!(.*\d){5,})[a-z0-9-]+$/mi
str = 'azv1232
v1v1v1v1v1v1
v1v1v1v1v1
xyzyzyzyzyzyzyzyzy
12345
1234
a1a1a1a1a1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end