#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9,.]+).*?([A-Z]{3})?$"
Local $sString = "$534" & @CRLF & _
"$22,136.20" & @CRLF & _
"3,200,000 Ft HUF" & @CRLF & _
"12,500 kr DKK" & @CRLF & _
"50,000 kr SEK" & @CRLF & _
"$3,800 AUD" & @CRLF & _
"$10,000 NZD" & @CRLF & _
"€4,500 EUR" & @CRLF & _
"¥100,000 CNY" & @CRLF & _
"₹7,000,000 INR" & @CRLF & _
"R$39,000 BRL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")