re = /([0-9,.]+).*?([A-Z]{3})?$/m
str = '$534
$22,136.20
3,200,000 Ft HUF
12,500 kr DKK
50,000 kr SEK
$3,800 AUD
$10,000 NZD
€4,500 EUR
¥100,000 CNY
₹7,000,000 INR
R$39,000 BRL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end