# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9,.]+).*?([A-Z]{3})?$"
test_str = ("$534\n"
"$22,136.20\n"
"3,200,000 Ft HUF\n"
"12,500 kr DKK\n"
"50,000 kr SEK\n"
"$3,800 AUD\n"
"$10,000 NZD\n"
"€4,500 EUR\n"
"¥100,000 CNY\n"
"₹7,000,000 INR\n"
"R$39,000 BRL")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.