#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)(?:[._-]|(\())([a-z]{2,3})(?(2)\)|)(?:[_\W]forced)?$"
Local $sString = "name.eng" & @CRLF & _
"name-eng" & @CRLF & _
"name(eng)" & @CRLF & _
"name(fri)_eng" & @CRLF & _
"name(fri)(eng)" & @CRLF & _
"name.eng.forced" & @CRLF & _
"name(eng).forced" & @CRLF & _
"name.(eng).forced" & @CRLF & _
"name.fri.eng.forced" & @CRLF & _
"name(fri).eng.forced" & @CRLF & _
"name.(fri).eng_forced" & @CRLF & _
"name-fri-eng.forced" & @CRLF & _
"name_(fri)_eng.forced" & @CRLF & _
"name(fri)_eng.forced" & @CRLF & _
"name(friday)_eng_forced" & @CRLF & _
"name(fri)(eng).forced" & @CRLF & _
"" & @CRLF & _
"I'm tying to extract the header and a 2 or 3 digit ISO 639 code from a string." & @CRLF & _
"" & @CRLF & _
"The general format of a valid string is:" & @CRLF & _
"" & @CRLF & _
"header + <special char> + <2 or 3 digit code> + (<special char>forced)" & @CRLF & _
"" & @CRLF & _
"The last section <special character>forced is optional and may or may not be present but if present forced must be preceded with a special character (like . or _ or -) for it to be a considered a valid string." & @CRLF & _
"" & @CRLF & _
"Examples of valid strings where the header and language code (eng) to be extracted are:" & @CRLF & _
"" & @CRLF & _
"name.eng" & @CRLF & _
"name-eng" & @CRLF & _
"name(eng)" & @CRLF & _
"name(fri)_eng" & @CRLF & _
"name(fri)(eng)" & @CRLF & _
"name.eng.forced" & @CRLF & _
"name(eng).forced" & @CRLF & _
"name.(eng).forced" & @CRLF & _
"name.fri.eng.forced" & @CRLF & _
"name(fri).eng.forced" & @CRLF & _
"name.(fri).eng_forced" & @CRLF & _
"name-fri-eng.forced" & @CRLF & _
"name_(fri)_eng.forced" & @CRLF & _
"name(fri)_eng.forced" & @CRLF & _
"name(friday)_eng_forced" & @CRLF & _
"name(fri)(eng).forced" & @CRLF & _
"" & @CRLF & _
"nameeng" & @CRLF & _
"nameeng.forced" & @CRLF & _
"name.eng).forced" & @CRLF & _
"name(fri)eng.forced" & @CRLF & _
"name(friday).engforced" & @CRLF & _
"name(fri)(eng)forced"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")