import re
regex = re.compile(r"^(.*?)(?:[._-]|(\())([a-z]{2,3})(?(2)\)|)(?:[_\W]forced)?$", flags=re.MULTILINE)
test_str = ("name.eng\n"
"name-eng\n"
"name(eng)\n"
"name(fri)_eng\n"
"name(fri)(eng)\n"
"name.eng.forced\n"
"name(eng).forced\n"
"name.(eng).forced\n"
"name.fri.eng.forced\n"
"name(fri).eng.forced\n"
"name.(fri).eng_forced\n"
"name-fri-eng.forced\n"
"name_(fri)_eng.forced\n"
"name(fri)_eng.forced\n"
"name(friday)_eng_forced\n"
"name(fri)(eng).forced\n\n"
"I'm tying to extract the header and a 2 or 3 digit ISO 639 code from a string.\n\n"
"The general format of a valid string is:\n\n"
"header + <special char> + <2 or 3 digit code> + (<special char>forced)\n\n"
"The last section <special character>forced is optional and may or may not be present but if present forced must be preceded with a special character (like . or _ or -) for it to be a considered a valid string.\n\n"
"Examples of valid strings where the header and language code (eng) to be extracted are:\n\n"
"name.eng\n"
"name-eng\n"
"name(eng)\n"
"name(fri)_eng\n"
"name(fri)(eng)\n"
"name.eng.forced\n"
"name(eng).forced\n"
"name.(eng).forced\n"
"name.fri.eng.forced\n"
"name(fri).eng.forced\n"
"name.(fri).eng_forced\n"
"name-fri-eng.forced\n"
"name_(fri)_eng.forced\n"
"name(fri)_eng.forced\n"
"name(friday)_eng_forced\n"
"name(fri)(eng).forced\n\n"
"nameeng\n"
"nameeng.forced\n"
"name.eng).forced\n"
"name(fri)eng.forced\n"
"name(friday).engforced\n"
"name(fri)(eng)forced")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")