const regex = /^(.*?)(?:[._-]|(\())([a-z]{2,3})(?(2)\)|)(?:[_\W]forced)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(?:[._-]|(\\())([a-z]{2,3})(?(2)\\)|)(?:[_\\W]forced)?$', 'gm')
const str = `name.eng
name-eng
name(eng)
name(fri)_eng
name(fri)(eng)
name.eng.forced
name(eng).forced
name.(eng).forced
name.fri.eng.forced
name(fri).eng.forced
name.(fri).eng_forced
name-fri-eng.forced
name_(fri)_eng.forced
name(fri)_eng.forced
name(friday)_eng_forced
name(fri)(eng).forced
I'm tying to extract the header and a 2 or 3 digit ISO 639 code from a string.
The general format of a valid string is:
header + <special char> + <2 or 3 digit code> + (<special char>forced)
The last section <special character>forced is optional and may or may not be present but if present forced must be preceded with a special character (like . or _ or -) for it to be a considered a valid string.
Examples of valid strings where the header and language code (eng) to be extracted are:
name.eng
name-eng
name(eng)
name(fri)_eng
name(fri)(eng)
name.eng.forced
name(eng).forced
name.(eng).forced
name.fri.eng.forced
name(fri).eng.forced
name.(fri).eng_forced
name-fri-eng.forced
name_(fri)_eng.forced
name(fri)_eng.forced
name(friday)_eng_forced
name(fri)(eng).forced
nameeng
nameeng.forced
name.eng).forced
name(fri)eng.forced
name(friday).engforced
name(fri)(eng)forced`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}