package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9!#$%&'*+\-\/=?^_`{|}~\.]{2,64}@[a-zA-Z0-9\-]{2,63}\.[a-zA-Z]{2,63}$`)
var str = `elafontsee@gmail.com
payton.banks@gmail.com
cr31293@gmail.com
bill@blanks.co
huey@s.com
sam@smith.c
elafontseausdfagsdfuyasdufyuasdyfuasdyfuyasdufyausdyfuasydfuyasfe@gmail.com`
var substitution = "Hello, $1 we thank you for subscribing! We're now hacking your domain ($2)!"
fmt.Println(re.ReplaceAllString(str, substitution))
}