const regex = /^[a-zA-Z0-9!#$%&'*+\-\/=?^_`{|}~\.]{2,64}@[a-zA-Z0-9\-]{2,63}\.[a-zA-Z]{2,63}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9!#$%&\'*+\\-\\\/=?^_`{|}~\\.]{2,64}@[a-zA-Z0-9\\-]{2,63}\\.[a-zA-Z]{2,63}$', 'gm')
const str = `elafontsee@gmail.com
payton.banks@gmail.com
cr31293@gmail.com
bill@blanks.co
huey@s.com
sam@smith.c
elafontseausdfagsdfuyasdufyuasdyfuasdyfuyasdufyausdyfuasydfuyasfe@gmail.com`;
const subst = `Hello, $1 we thank you for subscribing! We're now hacking your domain ($2)!`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);