# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z0-9!#$%&'*+\-\/=?^_`{|}~\.]{2,64}@[a-zA-Z0-9\-]{2,63}\.[a-zA-Z]{2,63}$"
test_str = ("elafontsee@gmail.com\n"
"payton.banks@gmail.com\n"
"cr31293@gmail.com\n"
"bill@blanks.co\n"
"huey@s.com\n"
"sam@smith.c\n"
"elafontseausdfagsdfuyasdufyuasdyfuasdyfuyasdufyausdyfuasydfuyasfe@gmail.com")
subst = "Hello, $1 we thank you for subscribing! We're now hacking your domain ($2)!"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.