using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":[a-z0-9]+(?:[-’_][a-z0-9]+)*:";
string input = @"Hello How are you :slight_smile::joy:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}