re = /:[a-z0-9]+(?:[-’_][a-z0-9]+)*:/m
str = 'Hello How are you :slight_smile::joy:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end