package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):[a-z0-9]+(?:[-’_][a-z0-9]+)*:`)
var str = `Hello How are you :slight_smile::joy:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}