using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\=%7)[A-Z]+(?=%)";
string input = @"onething=%7BABCDEFGHIJKLM%something=%7BNOPQRSTUVWXYZ%";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}