re = /(?<=\=%7)[A-Z]+(?=%)/
str = 'onething=%7BABCDEFGHIJKLM%something=%7BNOPQRSTUVWXYZ%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end