package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\b\w(?:\w\w)*\b,?)*$`)
var str = `aaffd,123,1,d3213,aaa,f
aaa,dd,1234,d,c
Should match:
aaffd,123,1,d3213,aaa,f
1
2,345,1
Should not match:
ad,ad
1,23,1,333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}