$re = '/^(?:\b\w(?:\w\w)*\b,?)*$/m';
$str = 'aaffd,123,1,d3213,aaa,f
aaa,dd,1234,d,c
Should match:
aaffd,123,1,d3213,aaa,f
1
2,345,1
Should not match:
ad,ad
1,23,1,333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);