// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\b\w(?:\w\w)*\b,?)*$").unwrap();
let string = "aaffd,123,1,d3213,aaa,f
aaa,dd,1234,d,c
Should match:
aaffd,123,1,d3213,aaa,f
1
2,345,1
Should not match:
ad,ad
1,23,1,333";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}