#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(longword1)(longword2)|.*\K(?1).*(?2)|.*\K(?2).*(?1)"
Local $sString = "A longword1 B longword2 C" & @CRLF & _
"A longword2 B longword1 C" & @CRLF & _
"A longword1 B longword1 C" & @CRLF & _
"A longword2 B longword2 C" & @CRLF & _
"A longword1 B" & @CRLF & _
"A longword2 C" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")