const regex = /(longword1)(longword2)|.*\K(?1).*(?2)|.*\K(?2).*(?1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(longword1)(longword2)|.*\\K(?1).*(?2)|.*\\K(?2).*(?1)', 'gm')
const str = `A longword1 B longword2 C
A longword2 B longword1 C
A longword1 B longword1 C
A longword2 B longword2 C
A longword1 B
A longword2 C
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}