use strict;
my $str = 'A longword1 B longword2 C
A longword2 B longword1 C
A longword1 B longword1 C
A longword2 B longword2 C
A longword1 B
A longword2 C
';
my $regex = qr/(longword1)(longword2)|.*\K(?1).*(?2)|.*\K(?2).*(?1)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}