#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s+[Aa]\d*\s+Sheet"
Local $sString = ", I want to extract A040 to excel collumn next to the filename." & @CRLF & _
"" & @CRLF & _
"Before the A040 there is always three empty spaces and than text Sheet (also in screenshoot) A040 Sheet" & @CRLF & _
"" & @CRLF & _
"Every file has different number and there is always letter A with three digits and text Sheet. --> example file uploaded: A040 Sheet" & @CRLF & _
"" & @CRLF & _
"I has something already in VB with Excel but it is not working. A040 Sheet"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")