import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+[Aa]\\d*\\s+Sheet";
final String string = ", I want to extract A040 to excel collumn next to the filename.\n\n"
+ "Before the A040 there is always three empty spaces and than text Sheet (also in screenshoot) A040 Sheet\n\n"
+ "Every file has different number and there is always letter A with three digits and text Sheet. --> example file uploaded: A040 Sheet\n\n"
+ "I has something already in VB with Excel but it is not working. A040 Sheet";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}