import re
regex = re.compile(r"\s+[Aa]\d*\s+Sheet")
test_str = (", I want to extract A040 to excel collumn next to the filename.\n\n"
"Before the A040 there is always three empty spaces and than text Sheet (also in screenshoot) A040 Sheet\n\n"
"Every file has different number and there is always letter A with three digits and text Sheet. --> example file uploaded: A040 Sheet\n\n"
"I has something already in VB with Excel but it is not working. A040 Sheet")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")