$re = '/\p{L}+(?:\se\s\p{L}+)+/u';
$str = 'foo aáà e bbb bar baz ccc e ddd e eéè qux';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);