// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\p{L}+(?:\se\s\p{L}+)+").unwrap();
let string = "foo aáà e bbb bar baz ccc e ddd e eéè qux";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}