const regex = new RegExp('\\b(?:MS|PhD)\\s*((?:(?!\\b(?:MS|PhD)\\b).)*)[.,]', 'g')
const str = `Candidate with MS or PhD in Statistics, Computer Science, or similar field.
Applicant with MS in Biology or Chemistry desired.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}