$re = '/\b(?:MS|PhD)\s*((?:(?!\b(?:MS|PhD)\b).)*)[.,]/';
$str = 'Candidate with MS or PhD in Statistics, Computer Science, or similar field.
Applicant with MS in Biology or Chemistry desired.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);