re = /\b(?:MS|PhD)\s*((?:(?!\b(?:MS|PhD)\b).)*)[.,]/
str = 'Candidate with MS or PhD in Statistics, Computer Science, or similar field.
Applicant with MS in Biology or Chemistry desired.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end