#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?!.*(Swans).*)).*(?!.*(Swans).*)"
Local $sString = "Seven Swans a Swimming" & @CRLF & _
"Six Geese a Laying" & @CRLF & _
"Five Golden Rings" & @CRLF & _
"Four Calling Birds" & @CRLF & _
"Three French Hens" & @CRLF & _
"Two Turtle Doves" & @CRLF & _
"and a Partridge in a Pear Tree"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")