re = /(?:(?!.*(Swans).*)).*(?!.*(Swans).*)/
str = 'Seven Swans a Swimming
Six Geese a Laying
Five Golden Rings
Four Calling Birds
Three French Hens
Two Turtle Doves
and a Partridge in a Pear Tree'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end