import re
regex = re.compile(r"(?:(?!.*(Swans).*)).*(?!.*(Swans).*)")
test_str = ("Seven Swans a Swimming\n"
"Six Geese a Laying\n"
"Five Golden Rings\n"
"Four Calling Birds\n"
"Three French Hens\n"
"Two Turtle Doves\n"
"and a Partridge in a Pear Tree")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")