const regex = /(?<group>[a-zA-Z0-9\[\]=\+\-\¿\?¡!<>$%\^&\*'"\sñÑáéíóúÁÉÍÓÚ]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<group>[a-zA-Z0-9\\[\\]=\\+\\-\\¿\\?¡!<>$%\\^&\\*\'"\\sñÑáéíóúÁÉÍÓÚ]+)', 'gm')
const str = `//abcdefghijklmnñopqrstuvwxyzñáéíóúABCDEFGHIJKLMNÑOPQRSTUVWXYZÁÉÍÓÚ0123456789[]=+-¿?¡!<>\$%^&*'()/#@*,.:;_| |||||||||| ] ¢£¤¥¦§¨©ª«¬®¯°±²³´µ¶¸¹º»¼½ mmmmm onload onclick='' [ ? / < ~ # \` ! @ \$ % ^ & * ( ) + = } | : ; ' , > { space !#\$%&'()*+,-./:;<=>?@[\\]^_\`{|}~ <html>sdsd</html> ** *\`\` \`\` ´´ {} {}[] \`\`\`\`... ;;,,´'¡'!!!!¿?ña ñaña ÑA á é´´ è ´ 8i ó ú à à\` à è\`ì\`ò ù & > < ksks < wksdsd '' \\" \\' <script>alert('hi')</script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}