#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d?|100)$"
Local $sString = "1" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"44" & @CRLF & _
"100" & @CRLF & _
"" & @CRLF & _
"0" & @CRLF & _
"101" & @CRLF & _
"200" & @CRLF & _
"2222" & @CRLF & _
"01" & @CRLF & _
"06" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")