$re = '/^([1-9]\d?|100)$/m';
$str = '1
9
10
44
100
0
101
200
2222
01
06
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);