package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]\d?|100)$`)
var str = `1
9
10
44
100
0
101
200
2222
01
06
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}