package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([#]+)\s*([^!]*)\s*(!\[.*\].*\))([^\n]*)`)
var str = `## Another Letter From The Editor
## Another Letter From The Editor `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}