$re = '/([#]+)\s*([^!]*)\s*(!\[.*\].*\))([^\n]*)/m';
$str = '## Another Letter From The Editor
## Another Letter From The Editor ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);