package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((http|https?)?(.+?\.?)(retailstore.com)(.+?\.?)?)`)
var str = `http://retailstore.com
https://retailstore.com
http://RETAILSTORE.com
HTTP://retailstore.com
HTTPS://retailstore.com
HTtP://RetaIlstore.com
https://test.retailstore.com
retailstore.com
test.com
http://test.com
http://test.retailstore.temp.com
http://xande.retailstore.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}