// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((http|https?)?(.+?\.?)(retailstore.com)(.+?\.?)?)").unwrap();
let string = "http://retailstore.com
https://retailstore.com
http://RETAILSTORE.com
HTTP://retailstore.com
HTTPS://retailstore.com
HTtP://RetaIlstore.com
https://test.retailstore.com
retailstore.com
test.com
http://test.com
http://test.retailstore.temp.com
http://xande.retailstore.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}