const regex = /((http|https?)?(.+?\.?)(retailstore.com)(.+?\.?)?)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http|https?)?(.+?\\.?)(retailstore.com)(.+?\\.?)?)', 'ig')
const str = `http://retailstore.com
https://retailstore.com
http://RETAILSTORE.com
HTTP://retailstore.com
HTTPS://retailstore.com
HTtP://RetaIlstore.com
https://test.retailstore.com
retailstore.com
test.com
http://test.com
http://test.retailstore.temp.com
http://xande.retailstore.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}