package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^"[a-zA-Z][\w\s\d#]+:\s*`)
var str = `"Martin: I'm hungry."
"kid#1:
"hello123:
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}