re = /^"[a-zA-Z][\w\s\d#]+:\s*/m
str = '"Martin: I\'m hungry."
"kid#1:
"hello123:
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end