$re = '/^"[a-zA-Z][\w\s\d#]+:\s*/m';
$str = '"Martin: I\'m hungry."
"kid#1:
"hello123:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);