package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/.*?[\r\n]*[\s?]`)
var str = `https://a.com/f sample words here https://b.com/g haha https://c.com/h `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}