re = /https?:\/\/.*?[\r\n]*[\s?]/m
str = 'https://a.com/f sample words here https://b.com/g haha https://c.com/h '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end