package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bHYD(?:\.|\b)`)
var str = `HYDRAULIC
HYD,CYLINDER
HYD,CYLINDER",
HYD. CYLINDER
HYD.,CYLINDER"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}